Partial Interruption - Students Joining Classes
Incident Report for DyKnow Cloud
Resolved
Service is completely restored.
Posted 12 months ago. Dec 12, 2017 - 11:32 EST
Monitoring
We're currently aware of an issue where students cannot join classes. We are actively working to resolve this issue.
Posted 12 months ago. Dec 12, 2017 - 10:46 EST