Interruption to Service
Incident Report for DyKnow Cloud
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 05, 2018 - 12:41 EDT
Identified
At 12:26 pm ET, DyKnow began experiencing an interruption in service. We are actively working towards a resolution.
Posted 6 months ago. Jun 05, 2018 - 12:28 EDT
This incident affected: DyKnow.me Website and Teacher Login.