Student Connectivity
Incident Report for DyKnow Cloud
Resolved
This incident has been resolved.
Posted 11 months ago. Jan 16, 2018 - 15:05 EST
Monitoring
Some teachers may experience issues with slow student connectivity. Please click "End" and start monitoring again to resolve this.
Posted 11 months ago. Jan 16, 2018 - 14:44 EST