Degraded Performance
Incident Report for DyKnow Cloud
Resolved
The issue was resolved at 11:20am EST.
Posted 10 months ago. Feb 06, 2018 - 11:21 EST
Investigating
Some teachers may be experiencing slow performance or be unable to monitor classes. We are currently investigating the situation.
Posted 10 months ago. Feb 06, 2018 - 10:40 EST