Joining Classes Issue
Incident Report for DyKnow Cloud
Resolved
This issue was resolved at 3:05pm ET.
Posted 11 months ago. Jan 26, 2018 - 15:30 EST
Monitoring
We are aware of an issue with students being unable to join classes. We are actively monitoring the issue now.
Posted 11 months ago. Jan 26, 2018 - 13:57 EST